GLSA-201311-16 : fcron: Information disclosure

Low Nessus Plugin ID 71090


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201311-16 (fcron: Information disclosure)

The fcrontab function contains a race condition relating to symlinks.
Impact :

A local attacker could perform symlink attacks to read arbitrary files with the privileges of the user running the application.
Workaround :

There is no known workaround at this time.


All fcron users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-process/fcron-3.0.5-r2'

See Also

Plugin Details

Severity: Low

ID: 71090

File Name: gentoo_GLSA-201311-16.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2013/11/26

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 1.9

Temporal Score: 1.7

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:fcron, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/11/25

Reference Information

CVE: CVE-2010-0792

BID: 38531

OSVDB: 62718

GLSA: 201311-16

CWE: 59