Amazon Linux AMI : ruby (ALAS-2013-248)

Medium Nessus Plugin ID 71079

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

Heap-based buffer overflow in Ruby 1.8, 1.9 before 1.9.3-p484, 2.0 before 2.0.0-p353, 2.1 before 2.1.0 preview2, and trunk before revision 43780 allows context-dependent attackers to cause a denial of service (segmentation fault) and possibly execute arbitrary code via a string that is converted to a floating point value, as demonstrated using (1) the to_f method or (2) JSON.parse.

Solution

Run 'yum update ruby' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2013-248.html

Plugin Details

Severity: Medium

ID: 71079

File Name: ala_ALAS-2013-248.nasl

Version: 1.5

Type: local

Agent: unix

Published: 2013/11/26

Updated: 2018/04/18

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:ruby, p-cpe:/a:amazon:linux:ruby-debuginfo, p-cpe:/a:amazon:linux:ruby-devel, p-cpe:/a:amazon:linux:ruby-irb, p-cpe:/a:amazon:linux:ruby-libs, p-cpe:/a:amazon:linux:ruby-rdoc, p-cpe:/a:amazon:linux:ruby-ri, p-cpe:/a:amazon:linux:ruby-static, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 2013/11/22

Reference Information

CVE: CVE-2013-4164

ALAS: 2013-248