Thunderbird < 24.1 NSS and NSPR Multiple Vulnerabilities (Mac OS X)

High Nessus Plugin ID 71043

Synopsis

The remote Mac OS X host contains a mail client that is potentially affected by multiple vulnerabilities.

Description

The installed version of Thunderbird is earlier than 24.1.1 and is, therefore, potentially affected by the following vulnerabilities :

- An error exists related to handling input greater than half the maximum size of the 'PRUint32' value.
(CVE-2013-1741)

- An error exists in the 'Null_Cipher' function in the file 'ssl/ssl3con.c' related to handling invalid handshake packets that could allow arbitrary code execution. (CVE-2013-5605)

- An error exists in the 'CERT_VerifyCert' function in the file 'lib/certhigh/certvfy.c' that could allow invalid certificates to be treated as valid.
(CVE-2013-5606)

- An integer truncation error exists in the function 'PL_ArenaAllocate' in the Netscape Portable Runtime (NSPR) library. (CVE-2013-5607)

Solution

Upgrade to Thunderbird 24.1.1 or later.

See Also

https://www.mozilla.org/en-US/security/advisories/mfsa2013-103/

http://www.nessus.org/u?61480ab5

https://developer.mozilla.org/en-US/docs/NSS/NSS_3.15.3_release_notes

Plugin Details

Severity: High

ID: 71043

File Name: macosx_thunderbird_24_1_1.nasl

Version: 1.5

Type: local

Agent: macosx

Published: 2013/11/22

Updated: 2018/07/14

Dependencies: 56557

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:thunderbird

Required KB Items: MacOSX/Thunderbird/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/11/19

Vulnerability Publication Date: 2013/11/12

Reference Information

CVE: CVE-2013-1741, CVE-2013-5605, CVE-2013-5606, CVE-2013-5607

BID: 63736, 63737, 63738, 63802