SAP Sybase Adaptive Server Enterprise Remote Code Execution (SAP Note 1893558)

High Nessus Plugin ID 70977

Synopsis

The version of SAP Sybase Adaptive Server Enterprise (ASE) installed on the remote host is affected by a remove code execution vulnerability.

Description

A buffer overflow vulnerability exists in SAP Sybase ASE. This enables an attacker to inject code into the working memory that is subsequently executed by the application. It can also be used to cause a general fault in the product, causing the product to terminate.

Solution

Apply one of the patches listed in the advisory.

See Also

https://service.sap.com/sap/support/notes/1893558

http://www.sybase.com/detail?id=1099371

Plugin Details

Severity: High

ID: 70977

File Name: sybase_ase_note1893558.nasl

Version: 1.8

Type: local

Agent: windows

Family: Windows

Published: 2013/11/20

Modified: 2018/08/08

Dependencies: 70970

Risk Information

Risk Factor: High

CVSSv2

Base Score: 8.7

Temporal Score: 7.6

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:P/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:sybase:adaptive_server_enterprise

Required KB Items: SMB/Sybase_ASE/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/05/31

Vulnerability Publication Date: 2013/09/06

Reference Information

BID: 63549

IAVA: 2013-A-0217