IBM DB2 10.1 < Fix Pack 3 Multiple Vulnerabilities (credentialed check)

Medium Nessus Plugin ID 70456


The remote database server is affected by multiple vulnerabilities.


According to its version, the installation of IBM DB2 10.1 on the remote host is affected by the following vulnerabilities :

- When a multi-node configuration is used, an error exists in the Fast Communications Manager (FCM) that could allow denial of service attacks. (CVE-2013-4032 / IC94434)

- An unspecified error exists that can allow an attacker to gain SELECT, INSERT, UPDATE, or DELETE permissions to database tables. Note that successful exploitation requires the rights EXPLAIN, SQLADM, or DBADM.
(CVE-2013-4033 / IC94757)


Apply IBM DB2 Version 10.1 Fix Pack 3 or later.

See Also

Plugin Details

Severity: Medium

ID: 70456

File Name: db2_101fp3_cred.nasl

Version: $Revision: 1.4 $

Type: local

Agent: windows

Family: Windows

Published: 2013/10/16

Modified: 2017/05/16

Dependencies: 70454

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:ibm:db2, cpe:/a:ibm:db2_connect

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/09/27

Vulnerability Publication Date: 2013/09/30

Reference Information

CVE: CVE-2013-4032, CVE-2013-4033

BID: 62018, 62747

OSVDB: 96654, 97950