ProSoft RadioLinx ControlScape PRNG Weakness

High Nessus Plugin ID 70416


The remote host has software that uses a weak password generator.


The remote host has a version of ProSoft RadioLinx ControlScape installed that has a flaw in the random number generator. This flaw could cause predictable passwords to be generated. A remote attacker could potentially exploit this by using a brute force attack in order to gain access to network devices managed by RadioLinx ControlScape.


Upgrade to RadioLinx v6.00.040 or later.

See Also

Plugin Details

Severity: High

ID: 70416

File Name: scada_radiolinx_controlscape_6_00_040.nbin

Version: $Revision: 1.22 $

Type: local

Family: SCADA

Published: 2013/10/14

Modified: 2018/01/29

Dependencies: 70415

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:prosoft-technology:radiolinx_controlscape

Required KB Items: SCADA/Apps/RadioLinx_ControlScape/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/08/09

Vulnerability Publication Date: 2013/09/05

Reference Information

CVE: CVE-2013-2803

BID: 62238

OSVDB: 97023

ICSA: 13-248-01