Opera < 15 UTF-8 Encoding XSS

Medium Nessus Plugin ID 70217

Synopsis

The remote host contains a web browser that is affected by a cross- site scripting vulnerability.

Description

The version of Opera installed on the remote host is a version prior to version 15. It is, therefore, vulnerable to cross-site scripting attacks due to improper validation of UTF-8 page encoding settings.

Solution

Upgrade to Opera 15 or later.

See Also

http://web.archive.org/web/20170722130524/http://www.opera.com:80/docs/changelogs/unified/1500/

Plugin Details

Severity: Medium

ID: 70217

File Name: opera_1500.nasl

Version: 1.6

Type: local

Agent: windows

Family: Windows

Published: 2013/09/30

Updated: 2018/11/15

Dependencies: 21746

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:opera:opera_browser

Required KB Items: SMB/Opera/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/07/02

Vulnerability Publication Date: 2013/09/12

Reference Information

CVE: CVE-2013-4705

BID: 62425

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990