GLSA-201309-20 : Dropbear: Multiple vulnerabilities

High Nessus Plugin ID 70160


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201309-20 (Dropbear: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Dropbear. Please review the CVE identifier and Gentoo bug referenced below for details.
Impact :

A remote attacker could send a specially crafted request to trigger a use-after-free condition, possibly resulting in arbitrary code execution or a Denial of Service condition. Additionally, the bundled version of libtommath has an error in its prime number generation, which could result in the generation of weak keys.
Workaround :

There is no known workaround at this time.


All Dropbear users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/dropbear-2012.55'

See Also

Plugin Details

Severity: High

ID: 70160

File Name: gentoo_GLSA-201309-20.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2013/09/27

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.1

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:H/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:dropbear, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/09/26

Reference Information

CVE: CVE-2012-0920

BID: 52159

OSVDB: 79590

GLSA: 201309-20