Firefox < 24.0 Multiple Vulnerabilities

High Nessus Plugin ID 69993


The remote Windows host contains a web browser that is potentially affected by multiple vulnerabilities.


The installed version of Firefox is earlier than 24.0 and is, therefore, potentially affected by the following vulnerabilities :

- Memory issues exist in the browser engine that could allow for denial of service or arbitrary code execution.
(CVE-2013-1718, CVE-2013-1719)

- The HTML5 Tree Builder does not properly maintain states, which could result in a denial of service or possible arbitrary code execution. (CVE-2013-1720)

- The ANGLE library is vulnerable to an integer overflow, which could result in a denial of service or arbitrary code execution. (CVE-2013-1721)

- Multiple use-after-free problems exist that could result in denial of service attacks or arbitrary code execution. (CVE-2013-1722, CVE-2013-1724, CVE-2013-1735, CVE-2013-1736, CVE-2013-1738)

- The NativeKey widget does not properly terminate key messages, possibly leading to a denial of service attack.

- Incorrect scope handling for JavaScript objects with compartments could result in denial of service or possibly arbitrary code execution. (CVE-2013-1725)

- Local users can gain the same privileges as the Mozilla Updater because the application does not ensure exclusive access to the update file. An attacker could exploit this by inserting a malicious file into the update file. (CVE-2013-1726)

- Sensitive information can be obtained via unspecified vectors because the IonMonkey JavaScript does not properly initialize memory. (CVE-2013-1728)

- A JavaScript compartment mismatch can result in a denial of service or arbitrary code execution. Versions of Firefox 20 or greater are not susceptible to the arbitrary code execution mentioned above.

- A buffer overflow is possible because of an issue with multi-column layouts. (CVE-2013-1732)

- An object is not properly identified during use of user-defined getter methods on DOM proxies. This could result in access restrictions being bypassed.


Upgrade to Firefox 24.0 or later.

See Also

Plugin Details

Severity: High

ID: 69993

File Name: mozilla_firefox_24.nasl

Version: $Revision: 1.8 $

Type: local

Agent: windows

Family: Windows

Published: 2013/09/19

Modified: 2017/06/09

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: Mozilla/Firefox/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/09/17

Vulnerability Publication Date: 2013/09/17

Reference Information

CVE: CVE-2013-1718, CVE-2013-1719, CVE-2013-1720, CVE-2013-1721, CVE-2013-1722, CVE-2013-1723, CVE-2013-1724, CVE-2013-1725, CVE-2013-1726, CVE-2013-1728, CVE-2013-1730, CVE-2013-1732, CVE-2013-1735, CVE-2013-1736, CVE-2013-1737, CVE-2013-1738

BID: 62460, 62462, 62463, 62464, 62465, 62466, 62467, 62468, 62469, 62470, 62472, 62473, 62475, 62478, 62479, 62482

OSVDB: 96201, 97387, 97388, 97389, 97390, 97391, 97392, 97395, 97397, 97398, 97399, 97400, 97401, 97402, 97403, 97404