GLSA-201309-07 : libotr: Arbitrary code execution

Medium Nessus Plugin ID 69898


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201309-07 (libotr: Arbitrary code execution)

Multiple heap-based buffer overflows are present in the Base64 decoder of libotr.
Impact :

A remote attacker could send a specially crafted OTR message, resulting in arbitrary code execution with the privileges of the process or a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All libotr users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-libs/libotr-3.2.1'

See Also

Plugin Details

Severity: Medium

ID: 69898

File Name: gentoo_GLSA-201309-07.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2013/09/15

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:libotr, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/09/15

Reference Information

CVE: CVE-2012-3461

BID: 54907

OSVDB: 84910

GLSA: 201309-07