Amazon Linux AMI : bind (ALAS-2012-113)

High Nessus Plugin ID 69603

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

An uninitialized data structure use flaw was found in BIND when DNSSEC validation was enabled. A remote attacker able to send a large number of queries to a DNSSEC validating BIND resolver could use this flaw to cause it to exit unexpectedly with an assertion failure.
(CVE-2012-3817)

Solution

Run 'yum update bind' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2012-113.html

Plugin Details

Severity: High

ID: 69603

File Name: ala_ALAS-2012-113.nasl

Version: 1.5

Type: local

Agent: unix

Published: 2013/09/04

Updated: 2018/04/18

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:bind, p-cpe:/a:amazon:linux:bind-chroot, p-cpe:/a:amazon:linux:bind-debuginfo, p-cpe:/a:amazon:linux:bind-devel, p-cpe:/a:amazon:linux:bind-libs, p-cpe:/a:amazon:linux:bind-sdb, p-cpe:/a:amazon:linux:bind-utils, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 2012/08/03

Reference Information

CVE: CVE-2012-3817

ALAS: 2012-113

RHSA: 2012:1123