Amazon Linux AMI : nginx (ALAS-2011-30)

medium Nessus Plugin ID 69589

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

Heap-based buffer overflow in compression-pointer processing in core/ngx_resolver.c in nginx before 1.0.10 allows remote resolvers to cause a denial of service (daemon crash) or possibly have unspecified other impact via a long response.

Solution

Run 'yum update nginx' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2011-30.html

Plugin Details

Severity: Medium

ID: 69589

File Name: ala_ALAS-2011-30.nasl

Version: 1.5

Type: local

Agent: unix

Published: 9/4/2013

Updated: 4/18/2018

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.4

CVSS v2

Risk Factor: Medium

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:nginx, p-cpe:/a:amazon:linux:nginx-debuginfo, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 12/13/2011

Reference Information

CVE: CVE-2011-4315

ALAS: 2011-30