Amazon Linux AMI : perl (ALAS-2011-19)

high Nessus Plugin ID 69578
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 6.7

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

A heap-based buffer overflow flaw was found in the way Perl decoded Unicode strings. An attacker could create a malicious Unicode string that, when decoded by a Perl program, would cause the program to crash or, potentially, execute arbitrary code with the permissions of the user running the program. (CVE-2011-2939)

It was found that the 'new' constructor of the Digest module used its argument as part of the string expression passed to the eval() function. An attacker could possibly use this flaw to execute arbitrary Perl code with the privileges of a Perl program that uses untrusted input as an argument to the constructor. (CVE-2011-3597)

Solution

Run 'yum update perl' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2011-19.html

Plugin Details

Severity: High

ID: 69578

File Name: ala_ALAS-2011-19.nasl

Version: 1.5

Type: local

Agent: unix

Published: 9/4/2013

Updated: 4/18/2018

Dependencies: ssh_get_info.nasl

Risk Information

Risk Factor: High

VPR Score: 6.7

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:2.3:o:amazon:linux:*:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-cpan:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-extutils-cbuilder:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-extutils-embed:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-io-zlib:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-locale-maketext-simple:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-module-corelist:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-module-loaded:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-object-accessor:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-package-constants:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-pod-escapes:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-time-piece:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-core:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-libs:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-archive-tar:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-archive-extract:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-cgi:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-cpanplus:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-compress-raw-zlib:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-compress-zlib:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-digest-sha:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-extutils-makemaker:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-extutils-parsexs:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-file-fetch:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-io-compress-base:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-io-compress-zlib:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-ipc-cmd:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-log-message:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-log-message-simple:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-module-build:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-module-load:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-module-load-conditional:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-module-pluggable:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-params-check:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-parse-cpan-meta:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-pod-simple:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-term-ui:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-test-harness:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-test-simple:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-time-hires:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-parent:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-suidperl:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:perl-version:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 11/9/2011

Reference Information

CVE: CVE-2011-3597, CVE-2011-2939

RHSA: 2011:1424

ALAS: 2011-19