Amazon Linux AMI : php (ALAS-2011-07)

high Nessus Plugin ID 69566
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

The MITRE CVE database describes these CVEs as :

Revert is_a() behavior to php <= 5.3.6 and add a new new option (allow_string) for the new behavior (accept string and raise autoload if needed)

Use-after-free vulnerability in the substr_replace function in PHP 5.3.6 and earlier allows context-dependent attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact by using the same variable for multiple arguments.

Stack-based buffer overflow in the socket_connect function in ext/sockets/sockets.c in PHP 5.3.3 through 5.3.6 might allow context-dependent attackers to execute arbitrary code via a long pathname for a UNIX socket.

The rfc1867_post_handler function in main/rfc1867.c in PHP before 5.3.7 does not properly restrict filenames in multipart/form-data POST requests, which allows remote attackers to conduct absolute path traversal attacks, and possibly create or overwrite arbitrary files, via a crafted upload request, related to a 'file path injection vulnerability.'

crypt_blowfish before 1.1, as used in PHP before 5.3.7 on certain platforms, does not properly handle 8-bit characters, which makes it easier for context-dependent attackers to determine a cleartext password by leveraging knowledge of a password hash.

PHP before 5.3.7 does not properly check the return values of the malloc, calloc, and realloc library functions, which allows context-dependent attackers to cause a denial of service (NULL pointer dereference and application crash) or trigger a buffer overflow by leveraging the ability to provide an arbitrary value for a function argument, related to (1) ext/curl/interface.c, (2) ext/date/lib/parse_date.c, (3) ext/date/lib/parse_iso_intervals.c, (4) ext/date/lib/parse_tz.c, (5) ext/date/lib/timelib.c, (6) ext/pdo_odbc/pdo_odbc.c, (7) ext/reflection/php_reflection.c, (8) ext/soap/php_sdl.c, (9) ext/xmlrpc/libxmlrpc/base64.c, (10) TSRM/tsrm_win32.c, and (11) the strtotime function.

Solution

Run 'yum upgrade php*' to upgrade your system.

See Also

http://www.nessus.org/u?f94687c5

https://admin.fedoraproject.org/updates/php-5.3.8-3.fc15

https://alas.aws.amazon.com/ALAS-2011-7.html

Plugin Details

Severity: High

ID: 69566

File Name: ala_ALAS-2011-07.nasl

Version: Revision: 1.7

Type: local

Agent: unix

Published: 9/4/2013

Updated: 1/27/2016

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.1

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:php, p-cpe:/a:amazon:linux:php-bcmath, p-cpe:/a:amazon:linux:php-cli, p-cpe:/a:amazon:linux:php-common, p-cpe:/a:amazon:linux:php-dba, p-cpe:/a:amazon:linux:php-debuginfo, p-cpe:/a:amazon:linux:php-devel, p-cpe:/a:amazon:linux:php-embedded, p-cpe:/a:amazon:linux:php-fpm, p-cpe:/a:amazon:linux:php-gd, p-cpe:/a:amazon:linux:php-imap, p-cpe:/a:amazon:linux:php-intl, p-cpe:/a:amazon:linux:php-ldap, p-cpe:/a:amazon:linux:php-mbstring, p-cpe:/a:amazon:linux:php-mcrypt, p-cpe:/a:amazon:linux:php-mssql, p-cpe:/a:amazon:linux:php-mysql, p-cpe:/a:amazon:linux:php-odbc, p-cpe:/a:amazon:linux:php-pdo, p-cpe:/a:amazon:linux:php-pgsql, p-cpe:/a:amazon:linux:php-process, p-cpe:/a:amazon:linux:php-pspell, p-cpe:/a:amazon:linux:php-snmp, p-cpe:/a:amazon:linux:php-soap, p-cpe:/a:amazon:linux:php-tidy, p-cpe:/a:amazon:linux:php-xml, p-cpe:/a:amazon:linux:php-xmlrpc, p-cpe:/a:amazon:linux:php-zts, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 10/11/2011

Reference Information

CVE: CVE-2011-1148, CVE-2011-1938, CVE-2011-2202, CVE-2011-2483, CVE-2011-3182, CVE-2011-3379

ALAS: 2011-07