GLSA-201309-01 : Cyrus-SASL: Denial of Service

Medium Nessus Plugin ID 69538


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201309-01 (Cyrus-SASL: Denial of Service)

In the GNU C Library (glibc) from version 2.17 onwards, the crypt() function call can return NULL when the salt violates specifications or the system is in FIPS-140 mode and a DES or MD5 hashed password is passed. When Cyrus-SASL’s authentication mechanisms call crypt(), a NULL may be returned.
Impact :

A remote attacker could trigger this vulnerability to cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All Cyrus-SASL users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-libs/cyrus-sasl-2.1.26-r3'

See Also

Plugin Details

Severity: Medium

ID: 69538

File Name: gentoo_GLSA-201309-01.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2013/09/02

Modified: 2016/05/12

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:cyrus-sasl, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/09/01

Reference Information

CVE: CVE-2013-4122

BID: 61164

OSVDB: 95172

GLSA: 201309-01