Apple QuickTime MPEG-2 Playback Component Code Execution

High Nessus Plugin ID 69422


The remote host contains a media decoding application that contains a remote code execution vulnerability.


The remote host contains a copy of the QuickTime MPEG-2 playback component, a commercial add-on to QuickTime distributed by Apple.

The remote version of this software is vulnerable to a remote code execution vulnerability. To exploit this flaw, an attacker would need to entice a user to view or process a maliciously crafter move file.


Upgrade to bersion of this component.

See Also

Plugin Details

Severity: High

ID: 69422

File Name: quicktime_mpeg2_760920.nasl

Version: $Revision: 1.7 $

Type: local

Agent: windows

Family: Windows

Published: 2013/08/21

Modified: 2015/01/15

Dependencies: 13855

Risk Information

Risk Factor: High


Base Score: 7.6

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:quicktime_mpeg-2_playback_component

Required KB Items: SMB/Registry/Enumerated

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/01/21

Vulnerability Publication Date: 2009/01/21

Reference Information

CVE: CVE-2009-0008

BID: 33393

OSVDB: 51531

CWE: 20