PuTTY 0.52 to 0.62 Multiple Vulnerabilities

Medium Nessus Plugin ID 69318


The remote Windows host has an SSH client that is affected by multiple vulnerabilities.


The remote host has an installation of PuTTY version 0.52 or greater but earlier than version 0.63. As such, it is reportedly affected by the following vulnerabilities :

- An overflow error exists in the function 'modmul' in the file 'putty/sshbn.c' that could allow heap corruption when handling DSA signatures. (CVE-2013-4206)

- A buffer overflow error exists related to modular inverse calculation, non-coprime values and DSA signature verification. (CVE-2013-4207)

- An error exists in the file 'putty/sshdss.c' that could allow disclosure of private key material.

- Multiple overflow errors exist in the files 'sshrsa.c' and 'sshdss.c'. (CVE-2013-4852)


Upgrade to PuTTY version 0.63 or later.

See Also






Plugin Details

Severity: Medium

ID: 69318

File Name: putty_063.nasl

Version: $Revision: 1.5 $

Type: local

Agent: windows

Family: Windows

Published: 2013/08/13

Modified: 2016/05/20

Dependencies: 57364

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:simon_tatham:putty

Required KB Items: installed_sw/PuTTY

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/08/06

Vulnerability Publication Date: 2013/08/06

Reference Information

CVE: CVE-2013-4206, CVE-2013-4207, CVE-2013-4208, CVE-2013-4852

BID: 61599, 61644, 61645, 61649

OSVDB: 95970, 96080, 96081, 96210