Cacti < 0.8.8b Command and SQL Injections

high Nessus Plugin ID 69306


The remote web server is running a PHP application that is affected by command injection and SQL injection vulnerabilities.


According to its self-reported version number, the Cacti application running on the remote web server is prior to version 0.8.8b. It is, therefore, potentially affected by command injection and SQL injection vulnerabilities because the application fails to properly sanitize user-supplied input to various scripts. An attacker may be able to exploit these issues to execute arbitrary code as well as access or modify the underlying database for the application.


Upgrade to Cacti 0.8.8b or later.

See Also

Plugin Details

Severity: High

ID: 69306

File Name: cacti_088b.nasl

Version: 1.10

Type: remote

Family: CGI abuses

Published: 8/12/2013

Updated: 6/5/2024

Configuration: Enable paranoid mode, Enable thorough checks

Supported Sensors: Nessus

Enable CGI Scanning: true

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/a:cacti:cacti

Required KB Items: www/PHP, Settings/ParanoidReport, installed_sw/cacti

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No known exploits are available

Patch Publication Date: 8/5/2013

Vulnerability Publication Date: 8/5/2013

Reference Information

CVE: CVE-2013-1434, CVE-2013-1435

BID: 61657, 61847