XnView 2.x < 2.04 Multiple Buffer Overflow Vulnerabilities

High Nessus Plugin ID 69137


The remote Windows host contains an application that is affected by multiple buffer overflow vulnerabilities.


The version of XnView installed on the remote Windows host is 2.x, earlier than 2.04. It is, therefore, reportedly affected by the following overflow vulnerabilities:

- An unspecified error exists that could allow a buffer overflow during 'PCT' file handling. (CVE-2013-2577)

- Unspecified errors exist that could allow heap-based buffer overflows during 'FPX' and 'PSP' file handling.
(CVE-2013-3492, CVE-2013-3493)


Upgrade to XnView version 2.04 or later.

See Also



Plugin Details

Severity: High

ID: 69137

File Name: xnview_2_04.nasl

Version: $Revision: 1.4 $

Type: local

Agent: windows

Family: Windows

Published: 2013/07/30

Modified: 2016/11/01

Dependencies: 30130

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:xnview:xnview

Required KB Items: SMB/XnView/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/07/18

Vulnerability Publication Date: 2013/07/22

Exploitable With

Core Impact

Reference Information

CVE: CVE-2013-2577, CVE-2013-3492, CVE-2013-3493

BID: 61397, 61503, 61505

OSVDB: 95580

Secunia: 54174

EDB-ID: 27049