Virtualizor < 2.3.1 Unspecified SQL Injection

High Nessus Plugin ID 69044

Synopsis

The remote web server contains an application that is affected by a SQL injection vulnerability.

Description

According to its version number, the Virtualizor install hosted on the remote web server is earlier than 2.3.1 and therefore affected by an unspecified SQL injection vulnerability, which could allow an attacker to inject or manipulate SQL queries on the applications database. This could lead to the manipulation or disclosure of arbitrary data. An attacker could also use this attack in order to elevate their privileges.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to version 2.3.1 or later.

See Also

http://www.nessus.org/u?c8c89805

http://www.virtualizor.com/blog/?p=352

Plugin Details

Severity: High

ID: 69044

File Name: virtualizor_231.nasl

Version: 1.4

Type: remote

Family: CGI abuses

Published: 2013/07/24

Updated: 2018/08/08

Dependencies: 69043

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: x-cpe:/a:softaculous:virtualizor

Required KB Items: www/virtualizor

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/06/21

Vulnerability Publication Date: 2013/06/24

Reference Information

BID: 61003