Hiawatha fetch_request Integer Overflow DoS

Medium Nessus Plugin ID 69040


The remote web server is affected by a denial of service vulnerability.


According to its Server response header, the installed version of Hiawatha is a version prior to 7.4.1. As such, it is affected by an integer overflow vulnerability in the 'fetch_request' function that could lead to a denial of service.


Upgrade to Hiawatha 7.4.1 or later.

See Also


Plugin Details

Severity: Medium

ID: 69040

File Name: hiawatha_fetch_request_dos.nasl

Version: $Revision: 1.2 $

Type: remote

Family: Web Servers

Published: 2013/07/24

Modified: 2014/05/24

Dependencies: 69032

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: x-cpe:/a:hiawatha:webserver

Required KB Items: Settings/ParanoidReport, www/hiawatha

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/02/26

Vulnerability Publication Date: 2011/02/26

Reference Information

BID: 60923

OSVDB: 94649