Hiawatha < 3.6 URL Handling Weakness

High Nessus Plugin ID 69037


The remote web server is affected by a URL handling weakness with an unspecified impact.


According to its server response header, the installed version of Hiawatha is a version prior to 3.6. A flaw exists in the handling of malicious characters within URLs that has an unspecified impact.


Upgrade to Hiawatha 3.6 or later.

See Also


Plugin Details

Severity: High

ID: 69037

File Name: hiawatha_url_handling_weakness.nasl

Version: $Revision: 1.2 $

Type: remote

Family: Web Servers

Published: 2013/07/24

Modified: 2014/05/24

Dependencies: 69032

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: x-cpe:/a:hiawatha:webserver

Required KB Items: Settings/ParanoidReport, www/hiawatha

Patch Publication Date: 2005/08/14

Vulnerability Publication Date: 2005/08/14

Reference Information

OSVDB: 94631