VLC < 2.0.7 Multiple Vulnerabilities

Medium Nessus Plugin ID 69015


The remote Windows host contains a media player that is affected by multiple vulnerabilities.


The version of VLC media player installed on the remote host is earlier than 2.0.7 and is, therefore, affected by the following vulnerabilities:

- The web interface contains a flaw that does not validate input passed via XML services resulting in a cross-site scripting vulnerability.

- A flaw exists in the XML services of the web interface that may allow a remote attacker to execute media player commands.

- A flaw exists that could lead to a denial of service / memory consumption when loading a malicious playlist.


Upgrade to VLC version 2.0.7 or later.

See Also




Plugin Details

Severity: Medium

ID: 69015

File Name: vlc_2_0_7.nasl

Version: $Revision: 1.5 $

Type: local

Agent: windows

Family: Windows

Published: 2013/07/23

Modified: 2015/02/13

Dependencies: 31852

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Required KB Items: SMB/VLC/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/05/26

Vulnerability Publication Date: 2013/06/10

Reference Information

CVE: CVE-2013-3564, CVE-2013-3565, CVE-2013-7340

BID: 60705, 66546

OSVDB: 94139, 94140, 94444, 104735

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990