Apache 2.2.x < 2.2.25 Multiple Vulnerabilities

Medium Nessus Plugin ID 68915


The remote web server may be affected by multiple cross-site scripting vulnerabilities.


According to its banner, the version of Apache 2.2.x running on the remote host is prior to 2.2.25. It is, therefore, potentially affected by the following vulnerabilities :

- A flaw exists in the 'RewriteLog' function where it fails to sanitize escape sequences from being written to log files, making it potentially vulnerable to arbitrary command execution. (CVE-2013-1862)

- A denial of service vulnerability exists relating to the 'mod_dav' module as it relates to MERGE requests.

Note that Nessus did not actually test for these issues, but instead has relied on the version in the server's banner.


Upgrade to Apache version 2.2.25 or later. Alternatively, ensure that the affected modules are not in use.

See Also




Plugin Details

Severity: Medium

ID: 68915

File Name: apache_2_2_25.nasl

Version: $Revision: 1.16 $

Type: remote

Family: Web Servers

Published: 2013/07/16

Modified: 2018/01/22

Dependencies: 48204

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:UR


Base Score: 5.6

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/07/10

Vulnerability Publication Date: 2013/05/13

Reference Information

CVE: CVE-2013-1862, CVE-2013-1896

BID: 59826, 61129

OSVDB: 93366, 95498