Apache 2.0.x < 2.0.65 Multiple Vulnerabilities

High Nessus Plugin ID 68914


The remote web server is affected by several vulnerabilities.


According to its banner, the version of Apache 2.0.x running on the remote host is prior to 2.0.65. It is, therefore, affected by several vulnerabilities :

- A flaw exists in the byte-range filter, making it vulnerable to denial of service. (CVE-2011-3192)

- A flaw exists in 'mod_proxy' where it doesn't properly interact with 'RewriteRule' and 'ProxyPassMatch' in reverse proxy configurations. (CVE-2011-3368)

- A privilege escalation vulnerability exists relating to a heap-based buffer overflow in 'ap_pregsub' function in 'mod_setenvif' module via .htaccess file.

- A local security bypass vulnerability exists within scoreboard shared memory that may allow the child process to cause the parent process to crash.

- A flaw exists within the status 400 code when no custom ErrorDocument is specified that could disclose 'httpOnly' cookies. (CVE-2012-0053)

- A flaw exists in the 'RewriteLog' function where it fails to sanitize escape sequences written to log files, which could result in arbitrary command execution.

Note that the remote web server may not actually be affected by these vulnerabilities. Nessus did not try to determine whether the affected modules are in use nor did it test for the issues themselves.


Upgrade to Apache version 2.0.65 or later. Alternatively, ensure that the affected modules are not in use.

See Also




Plugin Details

Severity: High

ID: 68914

File Name: apache_2_0_65.nasl

Version: $Revision: 1.16 $

Type: remote

Family: Web Servers

Published: 2013/07/16

Modified: 2018/01/23

Dependencies: 48204

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C


Base Score: 9.1

Temporal Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/07/10

Vulnerability Publication Date: 2011/08/20

Exploitable With

Core Impact

Reference Information

CVE: CVE-2011-3192, CVE-2011-3368, CVE-2011-3607, CVE-2012-0031, CVE-2012-0053, CVE-2013-1862

BID: 49303, 49957, 50494, 51407, 51706, 59826

OSVDB: 74721, 76079, 76744, 78293, 78556, 93366

EDB-ID: 17696, 17969, 18221, 18442