IrfanView < 4.36 Multiple Vulnerabilities

High Nessus Plugin ID 68888


A graphic viewer installed on the remote host is affected by multiple vulnerabilities.


The remote Windows host contains a version of IrfanView prior to version 4.36. It is, therefore, reportedly affected by multiple vulnerabilities :

- A heap-based buffer overflow vulnerability exists when parsing ANI images. An attacker can exploit this issue with a specially crafted ANI file, potentially leading to arbitrary code execution.

- A flaw exists where DCX file headers are not properly sanitized, which could potentially lead to a denial of service.

- An integer overflow vulnerability exists in the FlashPix Plugin (Fpx.dll) when handling sections of Summary Information Property sets, which could lead to arbitrary code execution.


Upgrade to IrfanView version 4.36 or later.

See Also

Plugin Details

Severity: High

ID: 68888

File Name: irfanview_436.nasl

Version: $Revision: 1.1 $

Type: local

Agent: windows

Family: Windows

Published: 2013/07/15

Modified: 2013/07/15

Dependencies: 57559

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:irfanview:irfanview

Required KB Items: SMB/IrfanView/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/05/30

Vulnerability Publication Date: 2013/05/27

Reference Information

CVE: CVE-2013-3486

BID: 61000

OSVDB: 93753, 94907