Oracle Linux 5 / 6 : perl (ELSA-2013-0685)

High Nessus Plugin ID 68797


The remote Oracle Linux host is missing one or more security updates.


From Red Hat Security Advisory 2013:0685 :

Updated perl packages that fix multiple security issues now available for Red Hat Enterprise Linux 5 and 6.

The Red Hat Security Response Team has rated this update as having moderate security impact. Common Vulnerability Scoring System (CVSS) base scores, which give detailed severity ratings, are available for each vulnerability from the CVE links in the References section.

Perl is a high-level programming language commonly used for system administration utilities and web programming.

A heap overflow flaw was found in Perl. If a Perl application allowed user input to control the count argument of the string repeat operator, an attacker could cause the application to crash or, potentially, execute arbitrary code with the privileges of the user running the application. (CVE-2012-5195)

A denial of service flaw was found in the way Perl's rehashing code implementation, responsible for recalculation of hash keys and redistribution of hash content, handled certain input. If an attacker supplied specially crafted input to be used as hash keys by a Perl application, it could cause excessive memory consumption.

It was found that the Perl CGI module, used to handle Common Gateway Interface requests and responses, incorrectly sanitized the values for Set-Cookie and P3P headers. If a Perl application using the CGI module reused cookies values and accepted untrusted input from web browsers, a remote attacker could use this flaw to alter member items of the cookie or add new items. (CVE-2012-5526)

It was found that the Perl Locale::Maketext module, used to localize Perl applications, did not properly handle backslashes or fully-qualified method names. An attacker could possibly use this flaw to execute arbitrary Perl code with the privileges of a Perl application that uses untrusted Locale::Maketext templates.

Red Hat would like to thank the Perl project for reporting CVE-2012-5195 and CVE-2013-1667. Upstream acknowledges Tim Brown as the original reporter of CVE-2012-5195 and Yves Orton as the original reporter of CVE-2013-1667.

All Perl users should upgrade to these updated packages, which contain backported patches to correct these issues. All running Perl programs must be restarted for this update to take effect.


Update the affected perl packages.

See Also

Plugin Details

Severity: High

ID: 68797

File Name: oraclelinux_ELSA-2013-0685.nasl

Version: $Revision: 1.12 $

Type: local

Agent: unix

Published: 2013/07/12

Modified: 2017/09/27

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:oracle:linux:perl, p-cpe:/a:oracle:linux:perl-Archive-Extract, p-cpe:/a:oracle:linux:perl-Archive-Tar, p-cpe:/a:oracle:linux:perl-CGI, p-cpe:/a:oracle:linux:perl-CPAN, p-cpe:/a:oracle:linux:perl-CPANPLUS, p-cpe:/a:oracle:linux:perl-Compress-Raw-Bzip2, p-cpe:/a:oracle:linux:perl-Compress-Raw-Zlib, p-cpe:/a:oracle:linux:perl-Compress-Zlib, p-cpe:/a:oracle:linux:perl-Digest-SHA, p-cpe:/a:oracle:linux:perl-ExtUtils-CBuilder, p-cpe:/a:oracle:linux:perl-ExtUtils-Embed, p-cpe:/a:oracle:linux:perl-ExtUtils-MakeMaker, p-cpe:/a:oracle:linux:perl-ExtUtils-ParseXS, p-cpe:/a:oracle:linux:perl-File-Fetch, p-cpe:/a:oracle:linux:perl-IO-Compress-Base, p-cpe:/a:oracle:linux:perl-IO-Compress-Bzip2, p-cpe:/a:oracle:linux:perl-IO-Compress-Zlib, p-cpe:/a:oracle:linux:perl-IO-Zlib, p-cpe:/a:oracle:linux:perl-IPC-Cmd, p-cpe:/a:oracle:linux:perl-Locale-Maketext-Simple, p-cpe:/a:oracle:linux:perl-Log-Message, p-cpe:/a:oracle:linux:perl-Log-Message-Simple, p-cpe:/a:oracle:linux:perl-Module-Build, p-cpe:/a:oracle:linux:perl-Module-CoreList, p-cpe:/a:oracle:linux:perl-Module-Load, p-cpe:/a:oracle:linux:perl-Module-Load-Conditional, p-cpe:/a:oracle:linux:perl-Module-Loaded, p-cpe:/a:oracle:linux:perl-Module-Pluggable, p-cpe:/a:oracle:linux:perl-Object-Accessor, p-cpe:/a:oracle:linux:perl-Package-Constants, p-cpe:/a:oracle:linux:perl-Params-Check, p-cpe:/a:oracle:linux:perl-Parse-CPAN-Meta, p-cpe:/a:oracle:linux:perl-Pod-Escapes, p-cpe:/a:oracle:linux:perl-Pod-Simple, p-cpe:/a:oracle:linux:perl-Term-UI, p-cpe:/a:oracle:linux:perl-Test-Harness, p-cpe:/a:oracle:linux:perl-Test-Simple, p-cpe:/a:oracle:linux:perl-Time-HiRes, p-cpe:/a:oracle:linux:perl-Time-Piece, p-cpe:/a:oracle:linux:perl-core, p-cpe:/a:oracle:linux:perl-devel, p-cpe:/a:oracle:linux:perl-libs, p-cpe:/a:oracle:linux:perl-parent, p-cpe:/a:oracle:linux:perl-suidperl, p-cpe:/a:oracle:linux:perl-version, cpe:/o:oracle:linux:5, cpe:/o:oracle:linux:6

Required KB Items: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/03/27

Exploitable With

Metasploit (TWiki MAKETEXT Remote Command Execution)

Elliot (TWiki 5.1.2 RCE)

Reference Information

CVE: CVE-2012-5195, CVE-2012-5526, CVE-2012-6329, CVE-2013-1667

BID: 56287, 56562, 56950, 58311

OSVDB: 86854, 87613, 88272, 90892

RHSA: 2013:0685