Oracle Linux 5 : xen (ELSA-2012-1236)

high Nessus Plugin ID 68614

Synopsis

The remote Oracle Linux host is missing a security update.

Description

The remote Oracle Linux 5 host has packages installed that are affected by a vulnerability as referenced in the ELSA-2012-1236 advisory.

- Qemu, as used in Xen 4.0, 4.1 and possibly other products, when emulating certain devices with a virtual console backend, allows local OS guest users to gain privileges via a crafted escape VT100 sequence that triggers the overwrite of a device model's address space. (CVE-2012-3515)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected xen, xen-devel and / or xen-libs packages.

See Also

https://linux.oracle.com/errata/ELSA-2012-1236.html

Plugin Details

Severity: High

ID: 68614

File Name: oraclelinux_ELSA-2012-1236.nasl

Version: 1.8

Type: local

Agent: unix

Published: 7/12/2013

Updated: 1/16/2024

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.8

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2012-3515

Vulnerability Information

CPE: p-cpe:/a:oracle:linux:xen, p-cpe:/a:oracle:linux:xen-devel, p-cpe:/a:oracle:linux:xen-libs, cpe:/o:oracle:linux:5

Required KB Items: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 9/5/2012

Vulnerability Publication Date: 11/23/2012

Reference Information

CVE: CVE-2012-3515

BID: 55413

RHSA: 2012:1236