Oracle Linux 3 : net-snmp (ELSA-2009-0295)

Medium Nessus Plugin ID 67806

Synopsis

The remote Oracle Linux host is missing one or more security updates.

Description

From Red Hat Security Advisory 2009:0295 :

Updated net-snmp packages that fix a security issue are now available for Red Hat Enterprise Linux 3.

This update has been rated as having moderate security impact by the Red Hat Security Response Team.

The Simple Network Management Protocol (SNMP) is a protocol used for network management.

It was discovered that the snmpd daemon did not use TCP wrappers correctly, causing network hosts access restrictions defined in '/etc/hosts.allow' and '/etc/hosts.deny' to not be honored. A remote attacker could use this flaw to bypass intended access restrictions.
(CVE-2008-6123)

This issue only affected configurations where hosts.allow and hosts.deny were used to limit access to the SNMP server. To obtain information from the server, the attacker would have to successfully authenticate, usually by providing a correct community string.

All net-snmp users should upgrade to these updated packages, which contain a backported patch to correct this issue. After installing the update, the snmpd and snmptrapd daemons will be restarted automatically.

Solution

Update the affected net-snmp packages.

See Also

https://oss.oracle.com/pipermail/el-errata/2009-March/000936.html

Plugin Details

Severity: Medium

ID: 67806

File Name: oraclelinux_ELSA-2009-0295.nasl

Version: 1.6

Type: local

Agent: unix

Published: 2013/07/12

Updated: 2019/09/30

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:oracle:linux:net-snmp, p-cpe:/a:oracle:linux:net-snmp-devel, p-cpe:/a:oracle:linux:net-snmp-libs, p-cpe:/a:oracle:linux:net-snmp-perl, p-cpe:/a:oracle:linux:net-snmp-utils, cpe:/o:oracle:linux:3

Required KB Items: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/03/26

Vulnerability Publication Date: 2009/02/12

Reference Information

CVE: CVE-2008-6123

BID: 33755

RHSA: 2009:0295

CWE: 20