Oracle Linux 3 : rdesktop (ELSA-2008-0576)

High Nessus Plugin ID 67720


The remote Oracle Linux host is missing a security update.


From Red Hat Security Advisory 2008:0576 :

Updated rdesktop packages that fix a security issues are now available for Red Hat Enterprise Linux 3.

This update has been rated as having moderate security impact by the Red Hat Security Response Team.

rdesktop is an open source client for Microsoft Windows NT Terminal Server and Microsoft Windows 2000 and 2003 Terminal Services, capable of natively using the Remote Desktop Protocol (RDP) to present the user's NT desktop. No additional server extensions are required.

An integer underflow vulnerability was discovered in the rdesktop. If an attacker could convince a victim to connect to a malicious RDP server, the attacker could cause the victim's rdesktop to crash or, possibly, execute an arbitrary code. (CVE-2008-1801)

Users of rdesktop should upgrade to these updated packages, which contain a backported patch to resolve this issue.


Update the affected rdesktop package.

See Also

Plugin Details

Severity: High

ID: 67720

File Name: oraclelinux_ELSA-2008-0576.nasl

Version: $Revision: 1.4 $

Type: local

Agent: unix

Published: 2013/07/12

Modified: 2015/12/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:oracle:linux:rdesktop, cpe:/o:oracle:linux:3

Required KB Items: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/07/24

Reference Information

CVE: CVE-2008-1801

BID: 29097

OSVDB: 44943

RHSA: 2008:0576

CWE: 189