Oracle Linux 3 : XFree86 (ELSA-2008-0502)

High Nessus Plugin ID 67700


The remote Oracle Linux host is missing one or more security updates.


From Red Hat Security Advisory 2008:0502 :

Updated XFree86 packages that fix several security issues are now available for Red Hat Enterprise Linux 3.

This update has been rated as having important security impact by the Red Hat Security Response Team.

XFree86 is an implementation of the X Window System, which provides the core functionality for the Linux graphical desktop.

An input validation flaw was discovered in's Security and Record extensions. A malicious authorized client could exploit this issue to cause a denial of service (crash) or, potentially, execute arbitrary code with root privileges on the X.Org server. (CVE-2008-1377)

Multiple integer overflow flaws were found in's Render extension. A malicious authorized client could exploit these issues to cause a denial of service (crash) or, potentially, execute arbitrary code with root privileges on the X.Org server. (CVE-2008-2360, CVE-2008-2361)

An input validation flaw was discovered in's MIT-SHM extension.
A client connected to the server could read arbitrary server memory. This could result in the sensitive data of other users of the server being disclosed. (CVE-2008-1379)

Users of XFree86 are advised to upgrade to these updated packages, which contain backported patches to resolve these issues.


Update the affected xfree86 packages.

See Also

Plugin Details

Severity: High

ID: 67700

File Name: oraclelinux_ELSA-2008-0502.nasl

Version: $Revision: 1.6 $

Type: local

Agent: unix

Published: 2013/07/12

Modified: 2017/08/15

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:oracle:linux:XFree86, p-cpe:/a:oracle:linux:XFree86-100dpi-fonts, p-cpe:/a:oracle:linux:XFree86-75dpi-fonts, p-cpe:/a:oracle:linux:XFree86-ISO8859-14-100dpi-fonts, p-cpe:/a:oracle:linux:XFree86-ISO8859-14-75dpi-fonts, p-cpe:/a:oracle:linux:XFree86-ISO8859-15-100dpi-fonts, p-cpe:/a:oracle:linux:XFree86-ISO8859-15-75dpi-fonts, p-cpe:/a:oracle:linux:XFree86-ISO8859-2-100dpi-fonts, p-cpe:/a:oracle:linux:XFree86-ISO8859-2-75dpi-fonts, p-cpe:/a:oracle:linux:XFree86-ISO8859-9-100dpi-fonts, p-cpe:/a:oracle:linux:XFree86-ISO8859-9-75dpi-fonts, p-cpe:/a:oracle:linux:XFree86-Mesa-libGL, p-cpe:/a:oracle:linux:XFree86-Mesa-libGLU, p-cpe:/a:oracle:linux:XFree86-Xnest, p-cpe:/a:oracle:linux:XFree86-Xvfb, p-cpe:/a:oracle:linux:XFree86-base-fonts, p-cpe:/a:oracle:linux:XFree86-cyrillic-fonts, p-cpe:/a:oracle:linux:XFree86-devel, p-cpe:/a:oracle:linux:XFree86-doc, p-cpe:/a:oracle:linux:XFree86-font-utils, p-cpe:/a:oracle:linux:XFree86-libs, p-cpe:/a:oracle:linux:XFree86-libs-data, p-cpe:/a:oracle:linux:XFree86-sdk, p-cpe:/a:oracle:linux:XFree86-syriac-fonts, p-cpe:/a:oracle:linux:XFree86-tools, p-cpe:/a:oracle:linux:XFree86-twm, p-cpe:/a:oracle:linux:XFree86-xauth, p-cpe:/a:oracle:linux:XFree86-xdm, p-cpe:/a:oracle:linux:XFree86-xfs, cpe:/o:oracle:linux:3

Required KB Items: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/06/12

Reference Information

CVE: CVE-2008-1377, CVE-2008-1379, CVE-2008-2360, CVE-2008-2361

BID: 29665, 29666, 29668, 29669

OSVDB: 46187, 46188, 46189, 46190

RHSA: 2008:0502

CWE: 189