Oracle Linux 3 / 4 : xpdf (ELSA-2007-0735)

Medium Nessus Plugin ID 67553

Synopsis

The remote Oracle Linux host is missing a security update.

Description

From Red Hat Security Advisory 2007:0735 :

Updated xpdf packages that fix a security issue in PDF handling are now available for Red Hat Enterprise Linux 2.1, 3, and 4.

This update has been rated as having important security impact by the Red Hat Security Response Team.

Xpdf is an X Window System-based viewer for Portable Document Format (PDF) files.

Maurycy Prodeus discovered an integer overflow flaw in the processing of PDF files. An attacker could create a malicious PDF file that would cause Xpdf to crash or potentially execute arbitrary code when opened.
(CVE-2007-3387)

All users of Xpdf should upgrade to these updated packages, which contain a backported patch to resolve this issue.

Solution

Update the affected xpdf package.

See Also

https://oss.oracle.com/pipermail/el-errata/2007-July/000288.html

https://oss.oracle.com/pipermail/el-errata/2007-July/000292.html

Plugin Details

Severity: Medium

ID: 67553

File Name: oraclelinux_ELSA-2007-0735.nasl

Version: 1.8

Type: local

Agent: unix

Published: 2013/07/12

Updated: 2019/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:oracle:linux:xpdf, cpe:/o:oracle:linux:3, cpe:/o:oracle:linux:4

Required KB Items: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/07/31

Vulnerability Publication Date: 2007/07/30

Exploitable With

Core Impact

Reference Information

CVE: CVE-2007-3387

BID: 25124

RHSA: 2007:0735

CWE: 189