Oracle Linux 3 / 4 : ruby (ELSA-2006-0604 / ELSA-2006-0729)

Medium Nessus Plugin ID 67399


The remote Oracle Linux host is missing a security update.


Updated ruby packages that fix security issues are now available.

This update has been rated as having moderate security impact by the Red Hat Security Response Team.

Ruby is an interpreted scripting language for object-oriented programming.

Users of Ruby should upgrade to these updated packages which contain backported patches and are not vulnerable to these issues.

From Red Hat Security Advisory 2006:0604 :

A number of flaws were found in the safe-level restrictions in Ruby. It was possible for an attacker to create a carefully crafted malicious script that can allow the bypass of certain safe-level restrictions. (CVE-2006-3694)

From Red Hat Security Advisory 2006:0729 :

A flaw was discovered in the way Ruby's CGI module handles certain multipart/form-data MIME data. If a remote attacker sends a specially crafted multipart-form-data request, it is possible to cause the ruby CGI script to enter an infinite loop, causing a denial of service. (CVE-2006-5467)


Update the affected ruby packages.

See Also

Plugin Details

Severity: Medium

ID: 67399

File Name: oraclelinux_ELSA-2006-0604.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2013/07/12

Modified: 2013/07/12

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:oracle:linux:irb, p-cpe:/a:oracle:linux:ruby, p-cpe:/a:oracle:linux:ruby-devel, p-cpe:/a:oracle:linux:ruby-docs, p-cpe:/a:oracle:linux:ruby-libs, p-cpe:/a:oracle:linux:ruby-mode, p-cpe:/a:oracle:linux:ruby-tcltk, cpe:/o:oracle:linux:3, cpe:/o:oracle:linux:4

Required KB Items: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2006/11/30

Reference Information

CVE: CVE-2006-3694, CVE-2006-5467

OSVDB: 11534, 27144, 34237

RHSA: 2006:0604, 2006:0729