PHP 5.3.x < 5.3.27 Multiple Vulnerabilities

Medium Nessus Plugin ID 67259

Synopsis

The remote web server uses a version of PHP that is potentially affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP 5.3.x installed on the remote host is prior to 5.3.27. It is, therefore, potentially affected by the following vulnerabilities:

- A buffer overflow error exists in the function '_pdo_pgsql_error'. (Bug #64949)

- A heap corruption error exists in numerous functions in the file 'ext/xml/xml.c'. (CVE-2013-4113 / Bug #65236)

Note that this plugin does not attempt to exploit these vulnerabilities, but instead relies only on PHP's self-reported version number.

Solution

Apply the vendor patch or upgrade to PHP version 5.3.27 or later.

See Also

https://bugs.php.net/bug.php?id=64949

https://bugs.php.net/bug.php?id=65236

http://www.php.net/ChangeLog-5.php#5.3.27

Plugin Details

Severity: Medium

ID: 67259

File Name: php_5_3_27.nasl

Version: 1.18

Type: remote

Family: CGI abuses

Published: 2013/07/12

Updated: 2018/11/15

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2013-4113

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2013/07/11

Vulnerability Publication Date: 2013/07/04

Reference Information

CVE: CVE-2013-4113

BID: 61128