Winamp < 5.64 Multiple Vulnerabilities

High Nessus Plugin ID 67207


The remote Windows host contains a multimedia application that is affected by multiple vulnerabilities.


The remote host is running Winamp, a media player for Windows.

The version of Winamp installed on the remote host is earlier than 5.64 and is, therefore, reportedly affected by the following vulnerabilities :

- A buffer overflow exists in the 'ml_local.dll' when passed GUI search fields.

- A buffer overflow exists in the 'gen_jumpex.dll' when handling Skins directory names.

- Invalid pointer dereference vulnerabilities exist in the 'gen_ff.dll' library when loading the links.xml.

Successful exploitation can allow arbitrary code execution.


Upgrade to Winamp 5.64 ( or later.

See Also

Plugin Details

Severity: High

ID: 67207

File Name: winamp_564.nasl

Version: $Revision: 1.2 $

Type: local

Agent: windows

Family: Windows

Published: 2013/07/09

Modified: 2013/09/07

Dependencies: 15817

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:nullsoft:winamp

Required KB Items: SMB/Winamp/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/06/19

Vulnerability Publication Date: 2013/07/01

Reference Information

CVE: CVE-2013-4694, CVE-2013-4695

BID: 60883, 60886

OSVDB: 94739, 94740, 94741

EDB-ID: 26557, 26558, 27874