OpenSSH LoginGraceTime / MaxStartups DoS

medium Nessus Plugin ID 67140
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote SSH service is susceptible to a remote denial of service attack.

Description

According to its banner, a version of OpenSSH earlier than version 6.2 is listening on this port. The default configuration of OpenSSH installs before 6.2 could allow a remote attacker to bypass the LoginGraceTime and MaxStartups thresholds by periodically making a large number of new TCP connections and thereby prevent legitimate users from gaining access to the service.

Note that this plugin has not tried to exploit the issue or detect whether the remote service uses a vulnerable configuration. Instead, it has simply checked the version of OpenSSH running on the remote host.

Solution

Upgrade to OpenSSH 6.2 and review the associated server configuration settings.

See Also

https://www.openwall.com/lists/oss-security/2013/02/06/5

http://openssh.org/txt/release-6.2

https://tools.cisco.com/security/center/viewAlert.x?alertId=28883

Plugin Details

Severity: Medium

ID: 67140

File Name: openssh_logingrace_dos.nasl

Version: 1.7

Type: remote

Published: 7/3/2013

Updated: 11/15/2018

Dependencies: ssh_detect.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.5

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 3/22/2013

Vulnerability Publication Date: 2/6/2013

Reference Information

CVE: CVE-2010-5107

BID: 58162