Mandriva Linux Security Advisory : puppet (MDVSA-2013:186)

High Nessus Plugin ID 67104


The remote Mandriva Linux host is missing one or more security updates.


Updated puppet packages fix remote code execution vulnerability

When making REST api calls, the puppet master takes YAML from an untrusted client, deserializes it, and then calls methods on the resulting object. A YAML payload can be crafted to cause the deserialization to construct an instance of any class available in the ruby process, which allows an attacker to execute code contained in the payload (CVE-2013-3567).


Update the affected puppet and / or puppet-server packages.

See Also

Plugin Details

Severity: High

ID: 67104

File Name: mandriva_MDVSA-2013-186.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2013/06/29

Modified: 2013/11/25

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:puppet, p-cpe:/a:mandriva:linux:puppet-server, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/06/28

Reference Information

CVE: CVE-2013-3567

BID: 60664

MDVSA: 2013:186