Google SketchUp < 13.0.3689 SKP Multiple Vulnerabilities

High Nessus Plugin ID 66926


A 3-D modeling application on the remote Windows host is affected by multiple buffer overflow vulnerabilities.


The version of Google SketchUp installed on the remote Windows host is earlier than 13.0.3689. As such, it reportedly is affected by multiple buffer overflows related to the handling of '.SKP' files. Specially crafted files containing BMP RLE4 compressed textures or MAC Pict textures can cause the application to crash or execute arbitrary code.


Upgrade to Trimble SketchUp 2013 (13.0.3689) or later.

See Also

Plugin Details

Severity: High

ID: 66926

File Name: google_sketchup_skp_multiple.nasl

Version: $Revision: 1.4 $

Type: local

Agent: windows

Family: Windows

Published: 2013/06/19

Modified: 2014/07/09

Dependencies: 56712

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:sketchup

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/05/21

Vulnerability Publication Date: 2013/05/23

Exploitable With

Core Impact

Reference Information

CVE: CVE-2013-3664, CVE-2013-7388

BID: 60248, 68451

OSVDB: 93787

IAVB: 2013-B-0063