Splunk 5.0.x < 5.0.3 Multiple Vulnerabilities

Medium Nessus Plugin ID 66835

Synopsis

The remote web server contains an application that is affected by multiple vulnerabilities.

Description

According to its version number, the Splunk Web hosted on the remote web server is affected by multiple vulnerabilities :

- The application is affected by an unspecified cross-site scripting vulnerability. An attacker can exploit this issue to inject arbitrary HTML and script code into a user's browser to be executed within the security context of the affected site. (CVE-2012-6447)

- The version of OpenSSL included with Splunk 5.x is affected by multiple vulnerabilities including a denial of service and a plaintext recovery attack.
(CVE-2013-0166, CVE-2013-0169)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Splunk 5.0.3 or later.

See Also

https://www.splunk.com/view/SP-CAAAHXG

http://docs.splunk.com/Special:SpecialLatestDoc?t=Documentation/Splunk/latest/ReleaseNotes/5.0.3

Plugin Details

Severity: Medium

ID: 66835

File Name: splunk_503.nasl

Version: 1.14

Type: remote

Family: CGI abuses

Published: 2013/06/06

Modified: 2018/11/15

Dependencies: 47619, 49069

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:splunk:splunk

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2013/05/28

Vulnerability Publication Date: 2013/05/28

Reference Information

CVE: CVE-2012-6447, CVE-2013-0166, CVE-2013-0169

BID: 57778, 60226, 60268

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990