Splunk 5.0.x < 5.0.3 Multiple Vulnerabilities

medium Nessus Plugin ID 66835


The remote web server contains an application that is affected by multiple vulnerabilities.


According to its version number, the Splunk Web hosted on the remote web server is affected by multiple vulnerabilities :

- The application is affected by an unspecified cross-site scripting vulnerability. An attacker can exploit this issue to inject arbitrary HTML and script code into a user's browser to be executed within the security context of the affected site. (CVE-2012-6447)

- The version of OpenSSL included with Splunk 5.x is affected by multiple vulnerabilities including a denial of service and a plaintext recovery attack.
(CVE-2013-0166, CVE-2013-0169)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Splunk 5.0.3 or later.

See Also



Plugin Details

Severity: Medium

ID: 66835

File Name: splunk_503.nasl

Version: 1.17

Type: remote

Family: CGI abuses

Published: 6/6/2013

Updated: 12/5/2022

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS Score Source: CVE-2012-6447

Vulnerability Information

CPE: cpe:/a:splunk:splunk

Required KB Items: installed_sw/Splunk

Exploit Ease: No exploit is required

Patch Publication Date: 5/28/2013

Vulnerability Publication Date: 5/28/2013

Reference Information

CVE: CVE-2012-6447, CVE-2013-0166, CVE-2013-0169

BID: 57778, 60226, 60268

CWE: 750, 751, 20, 74, 79, 442, 800, 629, 711, 801, 712, 722, 809, 725, 811, 864, 900, 928, 931, 990