VMware vCenter Multiple Vulnerabilities (VMSA-2012-0013)

Critical Nessus Plugin ID 66806

Synopsis

The remote host has a virtualization management application installed that is affected by multiple vulnerabilities.

Description

The version of VMware vCenter installed on the remote host is 4.0 earlier than Update 4a, 4.1 earlier than Update 3, or 5.0 earlier than Update 2. As such, it is potentially affected by multiple vulnerabilities in the included Oracle (Sun) Java Runtime Environment.

Solution

Upgrade to VMware vCenter Server 4.0 Update 4a / 4.1 Update 3 / 5.0 Update 2 or later.

See Also

http://www.vmware.com/security/advisories/VMSA-2012-0013.html

http://lists.vmware.com/pipermail/security-announce/2012/000197.html

Plugin Details

Severity: Critical

ID: 66806

File Name: vmware_vcenter_vmsa-2012-0013.nasl

Version: 1.9

Type: remote

Family: Misc.

Published: 2013/06/05

Modified: 2018/08/06

Dependencies: 63061

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_server

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/08/30

Vulnerability Publication Date: 2012/06/12

Exploitable With

CANVAS (CANVAS)

Core Impact

Metasploit (Java Applet Field Bytecode Verifier Cache Remote Code Execution)

Reference Information

CVE: CVE-2011-3563, CVE-2011-5035, CVE-2012-0497, CVE-2012-0498, CVE-2012-0499, CVE-2012-0500, CVE-2012-0501, CVE-2012-0502, CVE-2012-0503, CVE-2012-0504, CVE-2012-0505, CVE-2012-0506, CVE-2012-0507, CVE-2012-1711, CVE-2012-1713, CVE-2012-1716, CVE-2012-1717, CVE-2012-1718, CVE-2012-1719, CVE-2012-1720, CVE-2012-1723, CVE-2012-1725

BID: 51194, 52009, 52011, 52012, 52013, 52014, 52015, 52016, 52017, 52018, 52019, 52020, 52161, 53946, 53947, 53949, 53950, 53951, 53952, 53954, 53956, 53960

VMSA: 2012-0013

IAVA: 2012-A-0147