nginx ngx_http_proxy_module.c Memory Disclosure

Medium Nessus Plugin ID 66671


The remote web server is affected by a remote memory disclosure vulnerability.


According to its Server response header, the installed version of nginx is 1.1.x, greater than or equal to 1.1.4, or 1.2.x prior to 1.2.9. It is, therefore, affected by a memory disclosure vulnerability in 'ngx_http_proxy_module.c' when 'proxy_pass' to untrusted upstream servers is used.

By sending a specially crafted request, an attacker may be able to gain access to worker process memory or trigger a denial of service condition.


Either apply the patch manually or upgrade to nginx 1.2.9 or later.

See Also

Plugin Details

Severity: Medium

ID: 66671

File Name: nginx_1_2_9.nasl

Version: $Revision: 1.6 $

Type: remote

Family: Web Servers

Published: 2013/05/29

Modified: 2018/02/20

Dependencies: 106375

Risk Information

Risk Factor: Medium


Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Required KB Items: Settings/ParanoidReport, installed_sw/nginx

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/05/13

Vulnerability Publication Date: 2013/05/13

Reference Information

CVE: CVE-2013-2070

BID: 59824

OSVDB: 93282