PHP 5.4.x < 5.4.13 Information Disclosure

high Nessus Plugin ID 66585

Synopsis

The remote web server uses a version of PHP that is potentially affected by an information disclosure vulnerability.

Description

According to its banner, the version of PHP 5.4.x installed on the remote host is prior to 5.4.13. It is, therefore, potentially affected by an information disclosure vulnerability. The 5.4.12 fix for CVE-2013-1635 / CVE-2013-1643 was incomplete and an error still exists in the files 'ext/soap/php_xml.c' and 'ext/libxml/libxml.c' related to handling external entities. This error could cause PHP to parse remote XML documents defined by an attacker and could allow access to arbitraryfiles.

Note that this plugin does not attempt to exploit the vulnerability, but instead relies only on PHP's self-reported version number.

Solution

Upgrade to PHP version 5.4.13 or later.

See Also

http://www.nessus.org/u?7c770707

http://www.php.net/ChangeLog-5.php#5.4.13

Plugin Details

Severity: High

ID: 66585

File Name: php_5_4_13.nasl

Version: 1.11

Type: remote

Family: CGI abuses

Published: 5/24/2013

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2013-1635

CVSS v3

Risk Factor: High

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 3/14/2013

Vulnerability Publication Date: 3/5/2013

Reference Information

CVE: CVE-2013-1635, CVE-2013-1643, CVE-2013-1824

BID: 58224, 58766, 62373