Apache Tomcat 6.0.x < 6.0.37 Multiple Vulnerabilities

Medium Nessus Plugin ID 66426


The remote Apache Tomcat server is affected by multiple vulnerabilities.


According to its self-reported version number, the instance of Apache Tomcat 6.0 listening on the remote host is prior to 6.0.37. It is, therefore, affected by multiple vulnerabilities :

- An error exists related to chunked transfer encoding and extensions that allows limited denial of service attacks. (CVE-2012-3544)

- An error exists related to HTML form authentication and session fixation that allows an attacker to carry out requests using a victim's credentials. (CVE-2013-2067)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Tomcat version 6.0.37 or later.

See Also


Plugin Details

Severity: Medium

ID: 66426

File Name: tomcat_6_0_37.nasl

Version: $Revision: 1.12 $

Type: remote

Family: Web Servers

Published: 2013/05/15

Modified: 2018/01/24

Dependencies: 39446

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C


Base Score: 5.6

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/05/03

Vulnerability Publication Date: 2013/05/10

Reference Information

CVE: CVE-2012-3544, CVE-2013-2067

BID: 59797, 59799

OSVDB: 93252, 93253