MediaWiki 1.19.x < 1.19.6 / 1.20.x < 1.20.5 Multiple Vulnerabilities

medium Nessus Plugin ID 66390


The remote web server contains a PHP application that is affected by multiple vulnerabilities.


According to its version number, the instance of MediaWiki running on the remote host is affected by multiple security vulnerabilities :

- A flaw exists because the application fails to validate input passed via uploaded SVG files before returning it to the user. This allows a remote attacker to conduct cross-site scripting (XSS) attacks. (CVE-2013-2031)

- A flaw exists that allows an attacker to bypass the password change blocking mechanism. (CVE-2013-2032)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to MediaWiki version 1.19.6 / 1.20.5 or later.

See Also

Plugin Details

Severity: Medium

ID: 66390

File Name: mediawiki_1_19_6.nasl

Version: 1.12

Type: remote

Family: CGI abuses

Published: 5/13/2013

Updated: 4/11/2022

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2013-2032


Risk Factor: Low

Score: 3.7


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mediawiki:mediawiki

Required KB Items: Settings/ParanoidReport, installed_sw/MediaWiki, www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 4/30/2013

Vulnerability Publication Date: 4/30/2013

Reference Information

CVE: CVE-2013-2031, CVE-2013-2032

BID: 59594, 59595

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990