MediaWiki 1.19.x < 1.19.6 / 1.20.x < 1.20.5 Multiple Vulnerabilities

Medium Nessus Plugin ID 66390

Synopsis

The remote web server contains a PHP application that is affected by multiple vulnerabilities.

Description

According to its version number, the instance of MediaWiki running on the remote host is affected by multiple security vulnerabilities :

- A flaw exists because the application fails to validate input passed via uploaded SVG files before returning it to the user. This allows a remote attacker to conduct cross-site scripting (XSS) attacks. (CVE-2013-2031)

- A flaw exists that allows an attacker to bypass the password change blocking mechanism. (CVE-2013-2032)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MediaWiki version 1.19.6 / 1.20.5 or later.

See Also

http://www.nessus.org/u?f67370c9

https://www.mediawiki.org/wiki/Release_notes/1.19#MediaWiki_1.19.6

https://www.mediawiki.org/wiki/Release_notes/1.20#MediaWiki_1.20.5

Plugin Details

Severity: Medium

ID: 66390

File Name: mediawiki_1_19_6.nasl

Version: 1.10

Type: remote

Family: CGI abuses

Published: 2013/05/13

Updated: 2019/11/27

Dependencies: 19233

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2013-2032

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mediawiki:mediawiki

Required KB Items: Settings/ParanoidReport, installed_sw/MediaWiki, www/PHP

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/04/30

Vulnerability Publication Date: 2013/04/30

Reference Information

CVE: CVE-2013-2031, CVE-2013-2032

BID: 59594, 59595

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990