Joomla! 2.5.x < 2.5.10 / 3.0.x < 3.0.4 Multiple Vulnerabilities

Medium Nessus Plugin ID 66389

Synopsis

The remote web server contains a PHP application that is affected by multiple vulnerabilities.

Description

According to its self-identified version number, the Joomla! installation hosted on the remote web server is 2.5.x prior to 2.5.10 or 3.0.x prior to 3.0.4. It is, therefore, affected by multiple vulnerabilities :

- A security bypass vulnerability exists due to a failure to properly verify permissions before deleting private messages. An authenticated, remote attacker can exploit this to delete arbitrary private messages.
(CVE-2013-3056)

- An information disclosure vulnerability exists due to improper verification of permissions when viewing permission settings. An authenticated, remote attacker can exploit this to disclose restricted permission settings. (CVE-2013-3057)

- An unspecified cross-site scripting (XSS) vulnerability exists due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session.
(CVE-2013-3058)

- A cross-site scripting vulnerability (XSS) exists in the Voting plugin due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session. (CVE-2013-3059)

- A flaw exists in the remember.php script due to improper sanitization of input passed via a cookie parameter before being used in an unserialize() call.
An authenticated, remote attacker can exploit this to unserialize arbitrary PHP objects, resulting in a denial of service condition or a PHP object injection attack. (CVE-2013-3242)

- A cross-site scripting (XSS) vulnerability exists in the Highlighter plugin due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session. (CVE-2013-3267)

- A cross-site scripting (XSS) vulnerability exists in the Flash-Based File Uploader due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Joomla! version 2.5.10 / 3.0.4 / 3.1.0 or later.

See Also

http://www.nessus.org/u?93cf315a

http://www.nessus.org/u?1c07561c

Plugin Details

Severity: Medium

ID: 66389

File Name: joomla_2510.nasl

Version: 1.11

Type: remote

Family: CGI abuses

Published: 2013/05/13

Updated: 2019/11/27

Dependencies: 21142

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.5

Temporal Score: 4.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 5.4

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:joomla:joomla\!

Required KB Items: installed_sw/Joomla!, www/PHP, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/04/24

Vulnerability Publication Date: 2013/02/15

Reference Information

CVE: CVE-2013-3056, CVE-2013-3057, CVE-2013-3058, CVE-2013-3059, CVE-2013-3242, CVE-2013-3267

BID: 59483, 59484, 59485, 59486, 59487, 59489, 59490

EDB-ID: 25087

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990