MediaWiki 1.19.x < 1.19.5 / 1.20.x < 1.20.4 Multiple Vulnerabilities

Medium Nessus Plugin ID 66201


The remote web server contains a PHP application that is affected by multiple vulnerabilities.


According to its version number, the instance of MediaWiki running on the remote host is affected by multiple security vulnerabilities :

- A flaw exists because the application fails to validate input passed via Lua function names before returning it to the user. This allows a remote attacker to conduct cross-site scripting (XSS) attacks.

- Multiple XML external entity (XXE) flaws exist in 'Special:Import', 'SVG' parsing, and 'Extension:RSS' from untrusted sources. This allows a remote attacker to execute arbitrary commands and gain access to arbitrary files.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to MediaWiki version 1.19.5 / 1.20.4 or later.

See Also

Plugin Details

Severity: Medium

ID: 66201

File Name: mediawiki_1_19_5.nasl

Version: 1.12

Type: remote

Family: CGI abuses

Published: 2013/04/24

Updated: 2019/12/04

Dependencies: 19233

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2013-1951

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mediawiki:mediawiki

Required KB Items: Settings/ParanoidReport, installed_sw/MediaWiki, www/PHP

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/04/15

Vulnerability Publication Date: 2013/04/15

Reference Information

CVE: CVE-2013-1951

BID: 59077

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990