Mandriva Linux Security Advisory : quagga (MDVSA-2013:122)

Low Nessus Plugin ID 66134


The remote Mandriva Linux host is missing one or more security updates.


Updated quagga package fixes security vulnerability :

The bgp_capability_orf function in bgpd in Quagga and earlier allows remote attackers to cause a denial of service (assertion failure and daemon exit) by leveraging a BGP peering relationship and sending a malformed Outbound Route Filtering (ORF) capability TLV in an OPEN message (CVE-2012-1820).


Update the affected packages.

Plugin Details

Severity: Low

ID: 66134

File Name: mandriva_MDVSA-2013-122.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2013/04/20

Modified: 2013/11/25

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.9

Temporal Score: 2.5

Vector: CVSS2#AV:A/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64quagga-devel, p-cpe:/a:mandriva:linux:lib64quagga0, p-cpe:/a:mandriva:linux:quagga, p-cpe:/a:mandriva:linux:quagga-contrib, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/04/10

Reference Information

CVE: CVE-2012-1820

BID: 53775

MDVSA: 2013:122

MGASA: 2012-0133