Mandriva Linux Security Advisory : nss-pam-ldapd (MDVSA-2013:106)

Medium Nessus Plugin ID 66118


The remote Mandriva Linux host is missing a security update.


Updated nss-pam-ldapd packages fixes the following security vulnerability :

Garth Mollett discovered that a file descriptor overflow issue in the use of FD_SET() in nss-pam-ldapd can lead to a stack-based buffer overflow. An attacker could, under some circumstances, use this flaw to cause a process that has the NSS or PAM module loaded to crash or potentially execute arbitrary code.

The issue can be triggered in a network daemon by opening a large number of connections and forcing a name lookup. This would result in a crash and possibly remote code execution. This issue may also allow local privilege escalation if a suid program does name lookups and doesn't close file descriptors inherited from the parent process (CVE-2013-0288).


Update the affected nss-pam-ldapd package.

Plugin Details

Severity: Medium

ID: 66118

File Name: mandriva_MDVSA-2013-106.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2013/04/20

Modified: 2016/05/17

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:nss-pam-ldapd, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/04/10

Reference Information

CVE: CVE-2013-0288

BID: 58007

MDVSA: 2013:106

MGASA: 2013-0071