Mandriva Linux Security Advisory : mesa (MDVSA-2013:103)

Critical Nessus Plugin ID 66115

Synopsis

The remote Mandriva Linux host is missing one or more security updates.

Description

Updated mesa packages fix security vulnerability :

The glsl shaders are vulnerable to a buffer overrun in parcel_out_uniform_storage::visit_field. When too many uniforms are used, the error will now be caught in check_resources (src/glsl/linker.cpp) (CVE-2012-2864).

Additionally, Mesa has been updated to 8.0.4, fixing several bugs.

Solution

Update the affected packages.

Plugin Details

Severity: Critical

ID: 66115

File Name: mandriva_MDVSA-2013-103.nasl

Version: 1.6

Type: local

Published: 2013/04/20

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64dri-drivers, p-cpe:/a:mandriva:linux:lib64gbm1, p-cpe:/a:mandriva:linux:lib64gbm1-devel, p-cpe:/a:mandriva:linux:lib64glapi0, p-cpe:/a:mandriva:linux:lib64glapi0-devel, p-cpe:/a:mandriva:linux:lib64mesaegl1, p-cpe:/a:mandriva:linux:lib64mesaegl1-devel, p-cpe:/a:mandriva:linux:lib64mesagl1, p-cpe:/a:mandriva:linux:lib64mesagl1-devel, p-cpe:/a:mandriva:linux:lib64mesaglesv1_1, p-cpe:/a:mandriva:linux:lib64mesaglesv1_1-devel, p-cpe:/a:mandriva:linux:lib64mesaglesv2_2, p-cpe:/a:mandriva:linux:lib64mesaglesv2_2-devel, p-cpe:/a:mandriva:linux:lib64mesaglu1, p-cpe:/a:mandriva:linux:lib64mesaglu1-devel, p-cpe:/a:mandriva:linux:lib64mesaopenvg1, p-cpe:/a:mandriva:linux:lib64mesaopenvg1-devel, p-cpe:/a:mandriva:linux:lib64wayland-egl1, p-cpe:/a:mandriva:linux:lib64wayland-egl1-devel, p-cpe:/a:mandriva:linux:mesa, p-cpe:/a:mandriva:linux:mesa-common-devel, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/04/10

Reference Information

CVE: CVE-2012-2864

BID: 55135

MDVSA: 2013:103

MGASA: 2012-0264