Mandriva Linux Security Advisory : exif (MDVSA-2013:036)

Medium Nessus Plugin ID 66050


The remote Mandriva Linux host is missing a security update.


A vulnerability has been discovered and corrected in exif :

An integer overflow in the function jpeg_data_load_data in the exif program could cause a data read beyond the end of a buffer, causing an application crash or leakage of potentially sensitive information when parsing a crafted JPEG file (CVE-2012-2845).

The updated packages have been upgraded to the 0.6.21 version which is not vulnerable to this issue.


Update the affected exif package.

See Also

Plugin Details

Severity: Medium

ID: 66050

File Name: mandriva_MDVSA-2013-036.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2013/04/20

Modified: 2014/01/21

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.4

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:exif, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/04/05

Reference Information

CVE: CVE-2012-2845

BID: 54437

MDVSA: 2013:036